WordPress stopt ondersteuning Internet Explorer

Browsers. Je kunt erover blijven schrijven en praten. Als ontwikkelaar tenminste. Hoewel een browser op zich noodzakelijk is, zorgen de verschillen tussen al die browsers voor de nodige ontwikkeluitdagingen.

WordPress: discussie over browser ondersteuning

WordPress, het CMS wat we gebruiken voor ontwikkeling van websites, wordt gemaakt door een grote community. Binnen de gelederen van deze community is de afgelopen tijd heftig gediscussieerd over het al dan niet ondersteunen van (oudere) versies van Internet Explorer.

Geen WordPress ondersteuning voor Internet Explorer 8, 9 en 10

De uiteindelijke uitkomst van de discussie is dat de versies 8 t/m 10 van Internet Explorer niet meer worden ondersteund door WordPress vanaf versie 4.8. Om verschillende redenen, is dit eigenlijk een hele logische stap.

Het wereldwijde marktaandeel van deze 3 browserversies ligt net iets onder de 1%. Ook in Nederland laat dit beeld zich zien. In maart van dit jaar waren de versies opgeteld goed voor 0,82% marktaandeel, wanneer we alleen naar het aandeel desktop kijken.

WordPress is niet de eerste partij die ondersteuning voor deze versies van Internet Explorer staakt. Microsoft, ontwikkelaar van deze *kuch* fantastische browser, stopte ondersteuning al vroeg in 2016.

Een ander argument is de WordPress policy voor ‘Browser Support’. Bij andere browsers (Firefox, Chrome, Safari) wordt alleen de huidige en daaraan voorafgaande versie ondersteund. Voor Android browser en Chrome op Android wordt zelfs alleen de huidige versie ondersteund. Eigenlijk is het wat dat betreft al uniek dat van Internet Explorer zo lang prehistorische versies zijn ondersteund. Voor je beeldvorming: Internet Explorer 8 stamt uit het jaar 2008. De meest recente versie verscheen in februari 2011 en is dus ook al ruim 6 jaar oud.

Gevolgen

WordPress zal voor oude browsers niet direct onbruikbaar worden. Het stoppen van de ondersteuning richt zich vooral op de doorontwikkeling. Ontwikkelaars zullen er geen rekening meer mee hoeven te houden. Resultaat daarvan is dat bij gebruik van oude browsers het kan voorkomen dat bepaalde functionaliteiten niet werken. Eén van de eerste dingen die merkbaar zal worden, is dat de TinyMCE editor in nieuwe versies geen oude browsers meer ondersteunt. De WYSIWYG editor waarmee je opmaak toevoegt aan tekst bevat deze TinyMCE editor.

Oplossing

De oplossing is betrekkelijk eenvoudig. Gebruik een fatsoenlijke browser… of in ieder geval een browser die up-to-date is. Niet alleen is dat verstandig om te doen wanneer je WordPress gebruikt, maar ook je internetbeleving en veiligheid varen er wel bij.

 

Ook interessant

Cookies en privacy

Je weet dat ze er zijn: cookies. Per categorie kan je jouw keuze voor het gebruik van cookies aangeven. Deze methode komt overeen met de nieuwe AVG (ingangsdatum 25 mei 2018). Wij hebben de cookies van Google Analytics volledig geanonimiseerd en daarom mogen wij die plaatsen zonder toestemming. Op onze Privacy Pagina kan je hier meer over lezen.

Privacy policy | Sluiten
Instellingen

Niets meer missen?

 

 

Vul je gegevens in, dan houden wij je

op de hoogte van het laatste nieuws. 

Relax, we houden zelf ook niet van spam. We zullen je e-mail adres niet verkopen en sturen je niet vaker dan 1x per maand een bericht.